• J
    jflores13

    Hey, @phildunlap.

    No, it looks like it was run 1h afterwards. I am using the standard email template which includes the run duration, and since it is a very simple test report template, it only takes it under 2 seconds to complete. Last one took 1.92 seconds.

    And well, I have been using the email when the report gets to me, and that happens exactly 1 hour after the schedule. It is the Excel reports module, v3.5.1. My user (which is the Superadmin and creator of the report) is set to America/Mexico_City, and I can see the CST abbreviation under the time and date on the menu side bar, which is correct.

    And yes, that's also strange, if I run it with Run Now it gets generated and sent instantly.

    What I initially thought was programming it for 1h before, but the information it generates would be lacking 1h. Also, the email would be wrong because it does display the correct Run Time Start.

    It's as if the MangoES generated the report and just decided to wait exactly 1h to send it, but I am not sure if it generates it one hour later. I could check that out though, if it helps to bring more clarity to the issue.

    Thanks!

    posted in User help read more
  • J
    jflores13

    Hi,

    First of all, I apologize if this has been solved already.
    My problem is that I scheduled a report to be run every day in a MangoES, with the following cron pattern: 0 0 11 * * ?

    The strange thing that happens is that, even though the MangoES is in the correct time zone and displays the correct time and date, the report gets sent at 12:00 instead of 11:00, every day. Also, the email contents clearly show that it was scheduled for 11:00. Is this normal? What could I do to correct this 1-hour offset?

    Thanks in advance.

    posted in User help read more
  • J
    jflores13

    @jared-wiltshire Alright, I will try to enable the 2FA and use that port instead. Thanks again!

    posted in User help read more
  • J
    jflores13

    @jared-wiltshire I see.
    Why would Google say that Mango doesn't use modern security standards and, as a result, is "easier to break into"?
    And so, if I used 2 Step Verification I'd need to create an app password for mango and then use that one as the email account's password?

    posted in User help read more
  • J
    jflores13

    @jared-wiltshire

    I just managed to solve the rest of the issue. Being logged in, I clicked the profile pic, then Google Account/Security, then on the section of "Less secure app access" and turned that from "Don't allow" (recommended) to "Allow" (not recommended), and now it worked.

    Thanks for your replies, Jared.

    posted in User help read more
  • J
    jflores13

    Hey thanks @jared-wiltshire, I did try that before posting here, and I just tried again checking the TLS box, saving the conf, and clicking the "send test email button". Half-success. For some reason now it does try to log in but the error has to do with Google not allowing access to the application because it "doesn't meet the security requirements".
    I know now this doesn't have to do specifically with Mango, but do you happen to know how to overcome this easily?

    posted in User help read more
  • J
    jflores13

    Hi,
    I am trying to set up the email so I can start making excel reports testing, but when I try to send the test email, I get the following event:
    "Failed to send email titled "Mango test email" to "xxxx@xxxxx.com". Message: "Failed messages: com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.0 Must issue a STARTTLS command first. r1sm31895728oti.44 - gsmtp " "

    My settings are as follows:
    SMTP host: smpt.gmail.com, port 25. (Port 465 is closed)
    No TLS. Use Authorization.

    Do I need to do something else, power cycle the MangoES or something random?
    Thanks!

    posted in User help read more