• R
    Rafał B

    OK I got it to work.
    DasMbTCP have request Unit Id set to 255 and there's no posibility to change it, when i changed app slave id to 255 everything works like a charm.

    Is it possible to make modbus4j tcp slave to ignore Unit Id? Or some kind of setting to turn that off?

    posted in Modbus4J general discussion read more
  • R
    Rafał B

    I'm sorry for posting without any specific content but i didn't know what will be best.
    I think this isn't code specific problem, cause I'm just creating tcpslave and starting a listener on it and then getting and setting values in process image. I can post DASMbTcp setings screenshot if you want.

    I saved some wireshark logs, one with the working app and one with not working intouch.
    Link to files: Wireshark logs

    posted in Modbus4J general discussion read more
  • R
    Rafał B

    Hello,

    I have a problem. I'm writing an android app (slave simulator) with modbus tcp implementation and when I use ModbusPoll (Witte software) on Windows for testing everything works fine, but my goal is to communicate it with Intouch and Freelance.
    I can't get it to work with intouch, haven't tried freelance yet.
    As a ModbusTCP driver i use DASMbTcp and as far as Intouch connection works when i start dummy mobus slave on different machine on ModbusSlave(Witte software) app but when I try to do the same with my app it won't work.
    Could anyone help to resolve this problem?

    posted in Modbus4J general discussion read more