• R
    realmooseman

    Hey Folks,

    Thank you so much! It was indeed a newbie thing as suggested by Phil and Fox.

    Really appreciate your help.

    Jim.

    posted in Scripting general Discussion read more
  • R
    realmooseman

    Here is a simple snap shot of what I have done.
    testvar and var_oat are my data points in the scripting data source.

    So LOG.info will print the correct values when i run validate. I am aware of having to save

    0_1567094610888_code snip.JPG

    posted in Scripting general Discussion read more
  • R
    realmooseman

    Hi All,
    I am pretty sure this is newbie stuff, but I have set up a scripting datasource, added some external points, can make caculations on my points and when i validate the script, I can log.info values that seem to make sense. The problem is that none of my datapoints in my datasource receive values. I am thinking there is something simple I am missing, but can't figure it out.
    I set a CRON pattern for every 30 seconds, saved the script, enabled it, but can't think of what I am missing.
    When I look at the data points window, all the values show either a diamond with a question mark in them or No value.

    I have created my script which has 30 ish external points that I use to calculate a total energy, CO2 etc for an energy dashboard, and my datapoints I am hoping to track the individual calculated values for energy etc on each piece of equipment. Any thoughts?
    This is on 3.6
    I am certain it is just something I have either not set or shouldn't have set.

    Jim

    posted in Scripting general Discussion read more
  • R
    realmooseman

    Hi,

    Yes, in dashboard designer, I am adding components from the palette and one is the video component from the basic components tab.

    I want to have a background video which moves all the time, and then have a second video placed on top with alpha channel so transparent background which I can start and stop at specific points depending on data values, but the background continues to move.

    posted in User help read more
  • R
    realmooseman

    Hi All,
    I am attempting to have a couple video files overlay with alpha channel for transparency. Can someone tell me what codecs are supported and/or if I can add more codecs. I am having troubles finding specific documentation on the video component. I must be looking in the wrong places.

    THanks,

    Jim.

    posted in User help read more
  • R
    realmooseman

    Ok I did that and will recheck to see where I missed the documentation.

    I will have a look also at the user module. That seems like a good candidate.

    Thanks for the pointer

    Jim.

    posted in User help read more
  • R
    realmooseman

    Hi All,

    I have a video that I want to start and stop at certain points based on values from data points. How best would I do that?

    In dashboard designer, I can load my video and load my data points but not sure how to link the two together so the video will stop at either a certain time index or certain frame based on a value from my data point.
    Was also having trouble finding detail component documentation. Can someone point me to where I should look?

    Jim.

    posted in User help read more