• BG

    Hello,
    I was trying several permission variations and removed read permission to the entire filestore. The result was that I lost the logos and other image files that were uploaded for the dashboards but there was no change to the excel reports filestore for some reason. Each user was still able to see everyone's templates.

    Cheers

    Brian

    posted in User help read more
  • BG

    Hello all,
    First of all here are my system specs:
    Mango Core: 3.5.6
    Mango API: 3.5.2
    Mango UI: 3.5.5
    Platform: Centos 7.4.1708
    Java Version: 1.8.0_161

    One of our users have pointed out an issue with the file store for the Excel Report Templates. When one user is logged in and creates an excel report they can see everyone's templates in the folder. This is a data protection issue since the templates usually have the users name and site name in the title of the template.

    For example a user is logged in and would like to set up a new Excel report:
    0_1560340279163_fba40cc6-27fa-499a-82b3-e608f13798d1-image.png
    The reports from other users are not visible and that is great. but when they go to choose a file:

    0_1560340770231_17d6aea1-9b19-4474-9a10-a70c885dc435-image.png

    All the other user files are visible.

    I can't see anywhere in the system that allows me to put passwords on the templates to prevent this from happening.

    Is there anywhere in the background that I could add permissions to stop users from seeing other templates that do not belong to them?

    Cheers

    Brian

    p.s. I just checked the way the reports worked in mango 2.8. This is not an issue because the choose file button only gives the user the ability to browse their own local drives.

    posted in User help read more
  • BG

    Hello Jarrod,
    I have seen in some Java forums about the issue you mentioned. That would explain the differences that I have seen.

    I have taken your advice and set the env.properties file so that timezone=UTC and that seems to have solved the problem.

    My downloads are now giving correct times. And the cron patterns are now working and not changing the times!

    Thank you all for your help in sorting out a confusion for us.

    Cheers

    Brian

    posted in User help read more
  • BG

    Hello Jared,

    1. The Linux web server is set to UTC +0000 and will not adjust for daylight savings time. All of our loggers sync their time with the web server.

    2. From the env.properties file (both the default and the file in overrides) (no quotes in file):
      "# System time zone. Leave blank to use default VM time zone.
      timezone= "

    3. All of our users as set to "Use Server time zone"

    4. Here is the screen shot, but I notice since you are asking these questions that the Server and User time zones shown do not match what I have checked. Seems there may be an interpretation error here.
      0_1559212152685_8bc8748e-1e98-4083-a740-56a201834891-image.png

    5. We don't have any special programming for overrides or Angular. We only have the env.properties in the overrides folder.

    6. Mango Core: 3.5.6
      Mango API: 3.5.2
      Mango UI: 3.5.5
      Platform: Centos 7.4.1708

    Cheers

    Brian

    posted in User help read more
  • BG

    Hello Phil,
    Just to let you know, I purged the data for the 72 hour data point and reset it to use the cron pattern again. As you can see from the screen shot below, it has started to use the local time again. This is from the new UI pages.

    0_1559139765960_d063b3cc-912d-4b14-9b28-3c207b68d0d6-image.png

    The graph also shows the local time for that data point.

    And yet if I download the data from this page and choose the UTC time zone before I download the csv, all the data timestamps are using the correct server time not the local time.

    So I can assume that the data has been logged correct just not displayed correctly when using a cron pattern to update the data point.

    Cheers

    Brian

    posted in User help read more
  • BG

    Hello Phil,
    Thank you for your reply.
    I have tested the channels with the cache value used and it is working the way I need it to now.

    In regards to the local time appearing when I use the cron pattern to update the data point, It seems to happen in the new ui pages as well. Sort of.

    On the new watchlist UI, the graph shows the server times ok but the downloaded csv still shows local time for some reason. So it looks like the data was actually logged with local time. I have purged all the data from that data point and will look at it with the cron pattern again using the new UI pages only and let you know what I find.

    What I meant by the milliseconds lag is that I suspected that the data from the original meta data point did not get stored in the database before the extrapolated data used it for updates. So I thought it must take several milliseconds (or seconds even) for the original meta data point to get the new data from memory and store it into the database. This is confirmed by using the cached values as you suggested.

    So my issue is solved by using the cached values as well. But I still think there may be an issue if anyone needs to update using a cron pattern.

    Cheers

    Brian

    posted in User help read more
  • BG

    Hello,
    First of all I am using
    Mango Core: 3.5.6
    Mango API: 3.5.2
    Mango UI: 3.5.5
    Platform: Centos 7.4.1708
    Java Version: 1.8.0_161
    Browser: Chrome 72.0.3626.121 (Official Build) (64-bit)

    I am having a little bit of trouble getting some data points to behave properly.

    I have a rain bucket logger that updates every 10 minutes. From the channel "P01 - Rain Gauge" I have created 3 more channels that check the past 3 hours, 24 hours and 72 hours. Our server is set to GMT and does not adjust for daylight savings time.

    The 3 / 24/ 72 hour channels each use a simple script:
    return p1.past(HOUR, 3).sum;
    return p1.past(HOUR, 24).sum;
    return p1.past(HOUR, 72).sum

    where p1 is the variable set for the original channel

    Here is a screen shot of the watchlist:

    0_1559129876205_4a42dc82-58b6-4f00-98b0-9e69e40f3643-image.png

    In this screen shot the original channel "P01 - Rain Gauge" is correct for the latest 10 minute interval.

    The first problem I discovered is that the 3 / 24 / 72 hour channels were not picking up the latest reading. It seems that the update for these channel (triggered by the update of the original) happens just before the data is entered into the database. This is effectively making those readings 10 minutes behind.

    I have tried putting in an "Execution Delay" in the update settings under the script section of the meta point but this has had no affect on the timings.

    So I changed the 72 hour channel to use a cron pattern and update itself every 10 minutes and 30 seconds. The crom pattern was entered as: 30 0/10 * * * ?

    Now the value is correct as it has picked up the latest reading from the original channel. But the time has picked up local time and not the server time.

    So 2 issues I have encountered.

    1. The timing of updating the extrapolated data lags by probably milliseconds
    2. The appearance of local time when the server and loggers are set to GMT.

    Any suggestions on how to solve these issues would be greatly appreciated.

    p.s. the values for the 3 / 24 / and 72 hour readings should be the same in the screen shot as I have only been working on this for a couple of hours.

    Cheers

    Brian

    p.p.s. I have just checked the user time zone settings as well to see what affect they have on this issue. My user account is set to "Use server time zone" but if I change it to Etc/GMT which is the same time zone as the server is set to, the times on the watchlist reduce by an hour. This would make the 72 hour display correct but the other 3 channels show as an hour behind. So this is not a solution either.

    posted in User help read more
  • BG

    Hello Jarrod,
    Thank you, I will enter it manually.

    Cheers

    Brian

    posted in User help read more
  • BG

    Hello Mangoans,
    I am using the most up to date version of mango 3 at time of writing.

    I am trying to get an Excel report to run on a quarterly schedule. I have set up the schedule as shown in the screen shot:

    11 17 1 1 0/3 ? (these arae all selected from the drop downs, not entered manually)

    0_1553869924027_0a1efe53-d9d8-4782-a91a-29127ecdb19f-image.png

    But whenever I try to save I get a validation failed error.

    I have tried different combinations of "don't care" and "every" but they all come up with the validation error. It appears to not like the "every 3" month setting.

    Is there another way to get the report to run on the first day of every 3rd month?

    Cheers

    Brian

    posted in User help read more
  • BG

    Thanks Phil for clearing that up for me. That all makes sense now. I was wanting to capture more warnings on the Mango 3 server than I had on the Mango 2.

    Cheers

    Brian

    posted in User help read more