• D
    dkudos

    This is the Error I am receiving. 'Mitsubishi City Line': Function is not unicast, broadcast, or forward (0xa, 0xb, or 0x4). 'Mitsubishi City Line': is the Bacnet datapoint. I never had this error before just wondering what this means? Any idea let me know. I am running mango 1.13.0.

    Dominic

    posted in User help read more
  • D
    dkudos

    Hey All,

    I needed a solution for large 2 pipe steam boiler system zoned by room. It is controlled by a Wago 750-841 modbus ip unit. Firing RIB relays to turn on the boiler and put the T-Stats into day or night mode. My Scheduling is done with google calendars. I wrote a java app the connect via google's API. Need to integrate with mango let me know if it is possible. Also control a Mitsubishi City Line system via BACnet at the same time. Awesome! Would have not been possible without this app. I will post pics and other cool stuff once I am done.

    Dominic

    posted in Stories read more
  • D
    dkudos

    Hey guys and gals nice to find this program. I have a question. I have a Wago 750-841 Modbus TCP Controller which I am able to talk to with a Java program I and a friend wrote using the Jmod library. I tried your data source setup and when do a node scan I get 1 thru 240 nodes?! Correct me if I am wrong but if I have one modbus coupler at one ip should there not be only one node? What do you think? Also I have a Mitsubishi City Line System up and configured on Mango just fine. Bacnet seems to be fine.

    Let me know,

    dk

    posted in Hardware read more
  • D
    dkudos

    This is the Error I am receiving. 'Mitsubishi City Line': Function is not unicast, broadcast, or forward (0xa, 0xb, or 0x4). 'Mitsubishi City Line': is the Bacnet datapoint. I never had this error before just wondering what this means? Any idea let me know. I am running mango 1.13.0.

    Dominic

    posted in User help read more
  • D
    dkudos

    Hey All,

    I needed a solution for large 2 pipe steam boiler system zoned by room. It is controlled by a Wago 750-841 modbus ip unit. Firing RIB relays to turn on the boiler and put the T-Stats into day or night mode. My Scheduling is done with google calendars. I wrote a java app the connect via google's API. Need to integrate with mango let me know if it is possible. Also control a Mitsubishi City Line system via BACnet at the same time. Awesome! Would have not been possible without this app. I will post pics and other cool stuff once I am done.

    Dominic

    posted in Stories read more
  • D
    dkudos

    @zumiani said:

    You should look at the PLC program.
    Maybe a task turn it off after a while..
    Surely it isn't due to Mango or Modbus!

    Ok finally found the issue! I had created a binary 0 reset on the program I had wrote and was talking to mango at the same time. So everytime I had set a point in mango my program was reseting that point after 2 seconds.

    So now that I finally have it all working I am running a BAC-HD150 bacnet controller for the Mitsubishi City Line system with Bacnet IP of course. And running custom valve and boiler control for large steam system. I am controlling that with Wago 750-841 Modbus Field Coupler. I will update you with my setup once all is done.

    Thanks and hope this helps others.

    dk

    posted in Hardware read more
  • D
    dkudos

    @zumiani said:

    Modbus TCP device usually answer to all Modbus address.
    In fact, as you said, one IP address correspond to one Modbus device and so Modbus address is not so important.

    Got it thanks should have read this first. Still have a problem when setting a bit to the Wago. It sets fine but about 2 seconds or less it shuts off. I do not understand why? Is there something I am missing?

    dk

    posted in Hardware read more
  • D
    dkudos

    That is great and thank you for the response. What is bothering me is what function code mabey F7 is being used to scan nodes. I should see one node right? Also I can set a point with Mango and turn it on and off now but when I set a Modbus point it turns off after about 2 seconds. Mango says it is still set but the point on the wago has turned off. Why would it turn off if I have not told it to turn off? I have written a java program using Jmod library to do my own scheduling and have no problems with the Wago what do I not understand about Mango that would cause this? I really like this project and would like to help make it more useful as soon as I understand all of it.

    Any help would be great thanks,

    dk

    posted in Hardware read more
  • D
    dkudos

    Ok needed to set the offset to detect proper modbus port. But when I set a binary value it does not stay set on the wago but is still in mango. What do you think about that?

    dk

    posted in Hardware read more
  • D
    dkudos

    Hey guys and gals nice to find this program. I have a question. I have a Wago 750-841 Modbus TCP Controller which I am able to talk to with a Java program I and a friend wrote using the Jmod library. I tried your data source setup and when do a node scan I get 1 thru 240 nodes?! Correct me if I am wrong but if I have one modbus coupler at one ip should there not be only one node? What do you think? Also I have a Mitsubishi City Line System up and configured on Mango just fine. Bacnet seems to be fine.

    Let me know,

    dk

    posted in Hardware read more