• G
    georgestefan

    @phildunlap Hi, I've disconnected the other MangoES from the network, now I have only one that is getting data from the PLC, and I let it to run a while and I don't have any discarded polls.

    Thank you!

    posted in Mango Automation read more
  • G
    georgestefan

    @phildunlap Yes, is reading the values when is not discarding the polls.

    I've noticed that if I change the Data Source XID, 6 minutes after I've changed the XID the Data Source is working and I have successful polls but after that I get only Discarded polls.

    posted in Mango Automation read more
  • G
    georgestefan

    @phildunlap Hi, I've made the changes in the /system_settings.shtm page, I changed the Device ID and the Data Source XID but I get a lot of discarded polls...

    Any idea why?

    Thank you!

    posted in Mango Automation read more
  • G
    georgestefan

    @phildunlap What do you suggest? I can give you access to both MangoES if you want to.

    posted in Mango Automation read more
  • G
    georgestefan

    @phildunlap Yes, it's literally the same PLC an they are on the same network.

    posted in Mango Automation read more
  • G
    georgestefan

    @phildunlap I'm working a lot with the developer tools, and I clear the cash often.

    Just now I've noticed that on that MangoES where the points are not working properly I have a lot of discarded polls, 99%.

    Both MangoES get the data from the same PLC via BACnet IP, it's this a problem?

    posted in Mango Automation read more
  • G
    georgestefan

    @phildunlap Yes, I'm logged in with admin.

    And to your last question, I don't have them in other pages, this is the only page where they are.

    By downloading a failing series you are referring to that function to download the point data from the data_point_detail page, from mango interface? I've downloaded an excel document for the both points, from both MangoES, and I don't have any NaN or Infinity, only numbers.

    posted in Mango Automation read more
  • G
    georgestefan

    @phildunlap I will paste below the JSON code for the data sources:

    {
    "dataSources":[
    {
    "xid":"DS_4dc309c5-8959-488a-a217-c3d8e26b26e0",
    "name":"testBACnet",
    "enabled":true,
    "type":"BACnetIP",
    "alarmLevels":{
    "INITIALIZATION_EXCEPTION":"URGENT",
    "POLL_ABORTED":"URGENT",
    "DEVICE_EXCEPTION":"URGENT",
    "MESSAGE_EXCEPTION":"URGENT"
    },
    "purgeType":"YEARS",
    "updatePeriodType":"SECONDS",
    "covSubscriptionTimeoutMinutes":60,
    "localDeviceConfig":"68e37f9e-7aa7-431f-a9bb-fe2b5d77bce1",
    "updatePeriods":5,
    "editPermission":"",
    "purgeOverride":false,
    "purgePeriod":1
    }
    ]
    }

    This is for the MangoES that works, and below I'll put for the one that don't work:

    {
    "dataSources":[
    {
    "xid":"DS_4dc309c5-8959-488a-a217-c3d8e26b26e0",
    "name":"testBACnet",
    "enabled":true,
    "type":"BACnetIP",
    "alarmLevels":{
    "INITIALIZATION_EXCEPTION":"URGENT",
    "POLL_ABORTED":"URGENT",
    "DEVICE_EXCEPTION":"URGENT",
    "MESSAGE_EXCEPTION":"URGENT"
    },
    "purgeType":"YEARS",
    "updatePeriodType":"SECONDS",
    "covSubscriptionTimeoutMinutes":60,
    "localDeviceConfig":"68e37f9e-7aa7-431f-a9bb-fe2b5d77bce1",
    "updatePeriods":5,
    "editPermission":"",
    "purgeOverride":false,
    "purgePeriod":1
    }
    ]
    }

    And below is the JSON code for the point:

    {
    "dataPoints":[
    {
    "xid":"A100",
    "name":"CTWaterConsumption",
    "enabled":true,
    "loggingType":"INTERVAL",
    "intervalLoggingPeriodType":"MINUTES",
    "intervalLoggingType":"INSTANT",
    "purgeType":"YEARS",
    "pointLocator":{
    "dataType":"NUMERIC",
    "objectType":"ANALOG_VALUE",
    "propertyIdentifier":"present-value",
    "objectInstanceNumber":100,
    "remoteDeviceInstanceNumber":140,
    "settable":false,
    "useCovSubscription":false,
    "writePriority":16
    },
    "eventDetectors":[
    ],
    "plotType":"SPLINE",
    "rollup":"NONE",
    "unit":"",
    "templateXid":"Numeric 3min Integer",
    "simplifyType":"NONE",
    "chartColour":"black",
    "chartRenderer":{
    "type":"IMAGE",
    "timePeriodType":"DAYS",
    "numberOfPeriods":1
    },
    "dataSourceXid":"DS_4dc309c5-8959-488a-a217-c3d8e26b26e0",
    "defaultCacheSize":1,
    "deviceName":"testBACnet",
    "discardExtremeValues":false,
    "discardHighLimit":1.7976931348623157E308,
    "discardLowLimit":-1.7976931348623157E308,
    "intervalLoggingPeriod":3,
    "intervalLoggingSampleWindowSize":0,
    "overrideIntervalLoggingSamples":false,
    "preventSetExtremeValues":false,
    "purgeOverride":false,
    "purgePeriod":1,
    "readPermission":"test",
    "setExtremeHighLimit":1.7976931348623157E308,
    "setExtremeLowLimit":-1.7976931348623157E308,
    "setPermission":null,
    "tags":{
    },
    "textRenderer":{
    "type":"ANALOG",
    "useUnitAsSuffix":true,
    "unit":"",
    "renderedUnit":"",
    "format":"0"
    },
    "tolerance":0.0
    }
    ]
    }

    This is for the MangoES that works, and below I'll put for the one that don't work:

    {
    "dataPoints":[
    {
    "xid":"A100",
    "name":"CTWaterConsumption",
    "enabled":true,
    "loggingType":"INTERVAL",
    "intervalLoggingPeriodType":"MINUTES",
    "intervalLoggingType":"INSTANT",
    "purgeType":"YEARS",
    "pointLocator":{
    "dataType":"NUMERIC",
    "objectType":"ANALOG_VALUE",
    "propertyIdentifier":"present-value",
    "objectInstanceNumber":100,
    "remoteDeviceInstanceNumber":140,
    "settable":false,
    "useCovSubscription":false,
    "writePriority":16
    },
    "eventDetectors":[
    ],
    "plotType":"SPLINE",
    "rollup":"NONE",
    "unit":"",
    "templateXid":"Numeric 3min Integer",
    "simplifyType":"NONE",
    "chartColour":"black",
    "chartRenderer":{
    "type":"IMAGE",
    "timePeriodType":"DAYS",
    "numberOfPeriods":1
    },
    "dataSourceXid":"DS_4dc309c5-8959-488a-a217-c3d8e26b26e0",
    "defaultCacheSize":1,
    "deviceName":"testBACnet",
    "discardExtremeValues":false,
    "discardHighLimit":1.7976931348623157E308,
    "discardLowLimit":-1.7976931348623157E308,
    "intervalLoggingPeriod":3,
    "intervalLoggingSampleWindowSize":0,
    "overrideIntervalLoggingSamples":false,
    "preventSetExtremeValues":false,
    "purgeOverride":false,
    "purgePeriod":1,
    "readPermission":"test",
    "setExtremeHighLimit":1.7976931348623157E308,
    "setExtremeLowLimit":-1.7976931348623157E308,
    "setPermission":null,
    "tags":{
    },
    "textRenderer":{
    "type":"ANALOG",
    "useUnitAsSuffix":true,
    "unit":"",
    "renderedUnit":"",
    "format":"0"
    },
    "tolerance":0.0
    }
    ]
    }

    Also, will be a good idea to purge any point values to see if this is the reason? Maybe is there a value that is corrupted or something...

    posted in Mango Automation read more
  • G
    georgestefan

    @phildunlap But I have on another MangoES the same data source and the same JavaScript code and it's working, I don't get this error. An this is strange and I don't see why is happening...

    posted in Mango Automation read more